Подпишитесь на рассылку о самых интересных материалах в мире веб-разработки :)

Bootstrap 4, ошибка при старте сервера


(Grayson Abel) #1

заметил, проблемку при старте сервера… Что это может быть?

bootstrap и bootstrap-sass установлен согласно инструкции гитхаба

/Gemfile

gem 'bootstrap-sass', '~> 3.3.6'
gem 'bootstrap', '~> 4.0.0.alpha6'
source 'https://rails-assets.org' do
  gem 'rails-assets-tether', '>= 1.3.3'
end

/application.js

//= require jquery
//= require jquery_ujs
//= require turbolinks
//= require trix
//= require_tree .
//= require bootstrap-sprockets

/application.scss


 *= require trix
 *= require_tree .
 *= require_self
 */
@import "bootstrap-sprockets";
@import "bootstrap";

(Kvokka) #2

у тебя в Gemfile, bootstrap 2 раза добавлен.
либо бутсрап-сасс 3, либо 4


(Grayson Abel) #3

Да, спасибо, удалил сасс, все норм, только проблемка теперь с navbar’ом, но мб решу сам)