Подпишитесь на рассылку о самых интересных материалах в мире веб-разработки :)

Обучение по Ruby on Rails Tutorial Майкла Хартла


(Евгений) #1

Данная тема создана в помощь новичкам в освоении RoR, которые начали свой путь с Туториала Майкла Хартла.


(Евгений) #2

Подскажите, пожалуйста, выдает следующую ошибку:

An error occurred while installing json (1.8.6), and Bundler cannot
continue.
Make sure that gem install json -v '1.8.6' succeeds before bundling.


(Kvokka) #3

так тут ре записано, что тебе нужно установить гем json версии 1.8.6
а вообще, в начале, советую отложить Хартла и пойти на курс английского для начинающих


(Evgeniy) #4

http://frey.su/google-it/


(Anton Melnik) #5

В Хартле в принципе все достаточно примитивно и нет проблем, которые нельзя загуглить.


(Сергей) #6

Вопрос по главе 5 Hartl.
При подключениии Bootstrap Листинг 5.5. Добавление Bootstrap CSS.
app/assets/stylesheets/custom.css.scss

@import “bootstrap”;
вылетает ошибка в браузере
() Sass::SyntaxError in StaticPages#home

Extracted source (around line #5):

<%= full_title(yield(:title)) %> <%= stylesheet_link_tag "application", media: "all", "data-turbolinks-track" => true %> <%= javascript_include_tag "application", "data-turbolinks-track" => true %> <%= csrf_meta_tags %>

(Kvokka) #7

Ну так синтаксическая ошибка. бегло в глаза не бросилась, иди на указанную строку и лови дзен


(Сергей) #8

Там едиственная строка
@import “bootstrap”;


(Kvokka) #9

ну так ты импортируешь application , а ошибки нет в custom
пройдись по импортируемому application.scss, попробуй поотключать и узнаешь где не так. дальше уже копай


(Viacheslav) #10

установил Rails 5.0. и Ruby 2.4.2 И с начала изучения уже вопросики вылезли. В главе 1.2.4. когда надо исправлять строчки в гемфайл Gemfile в first_app при операции bundle update и bundle install вылезают следующие ошибки:

Bundler could not find compatible versions for gem "coffee-rails":
  In Gemfile:
    coffee-rails (= 4.0.1)
    turbolinks (= 1.1.1) was resolved to 1.1.1, which depends on
      coffee-rails
Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    jquery-rails (= 3.0.4) was resolved to 3.0.4, which depends on
      railties (< 5.0, >= 3.0)
    rails (= 5.1.4) was resolved to 5.1.4, which depends on
      railties (= 5.1.4)
    sass-rails (= 4.0.1) was resolved to 4.0.1, which depends on
      railties (< 5.0, >= 4.0.0)

на Stackoverflow посоветовали убрать gemfile.lock. Так и сделал, но ошибка не откатилась.


(Сергей) #11

После удаления lock bundle update сделали?


(Viacheslav) #12

Делал, но ничего не поменялось.
Может нужно поставить версии Руби и Rails из учебника,я так понимаю, что ранние версии гемов могут не поддерживаться в поздних версиях программ?


(Сергей) #13

Поставьте свежие версии гемов, я дума не принципиально именно такие как в книге использовать


(Viacheslav) #14

поставил, но автор советует, что новые гемы могу вызывать казусы в данном проекте. Спасибо, будем дальше разбираться!


#15

Уберите номера версий гемов в гемфайле; некоторые, либо все. Стандартная проблема.


(Viacheslav) #16

Добрался до главы развертывание приложения на heroku,но вот беда, и тут оказия вылезла:

 Application error

An error occurred in the application and your page could not be served. If you are the application owner, check your logs for details. 

Логи с Херуку есть ли смысл сюда выкладывать? потому что там очень много текста и страшно нарваться на бан в этом форуме.


(Evgeniy) #17

Я не баню за логи :smiley:


(Ира) #18

Изучай Ruby on Rails по Ruby On Rails Tutoral by Michaele Hartl. Не могу разобраться 5.1.2 Bootstrap и кастомные CSS. Делаю все по книге:
Обновляю Gemfile - gem ‘bootstrap-sass’, '3.3.7’
Устанавливаю - bundle install
Создаю файл - /app/assets/stylesheets/custom.scss
В этом файле делаю @import “bootstrap-sprockets”; @import “bootstrap”;
И делаю рестарт сервера
В итоге стили не применяются и страница остается прежней. Я так понимаю, что Bootstrap фреймворк не работает… Кто может подсказать чего-то по этому поводу?


(Kvokka) #19

местами попробуй поменять bootstrap-sprokets и bootstrap


(Bacb) #20

Проверь подключен ли custom.scss в applications.scss